Добро пожаловать, Гость. Пожалуйста, выберите Вход или Регистрация
   
  ГлавнаяСправкаПоискВходРегистрация  
 
Переключение на Главную Страницу Страниц: 1
Печать
Команды telnet помогите пожалуйста (Прочитано 1 583 раз)
SEGА
Модератор
*****
Вне Форума


Жить трудно, но с%ка ИНТЕРЕСНО!

Настрочил: 2 519
Краснотурьинск
Пол: male
Команды telnet помогите пожалуйста
31.08.2015 :: 15:33:29
 
Стоит задача перезапустить модем по батнику
загвоздка встала в прописи логина и пароля они должны так же с этого батника вводится.
Code:
telnet 192.168.1.2 


...
логин admin
пароль admin
и в конце нужно прописать reboot

помогите пожалуйста
Наверх
 

Системы охраны и видеонаблюдения
http://sega.3dn.ru
WWW SEGА SEGA_xXx 458753302  
IP записан
 
FiN
Админ
*****
Вне Форума



Настрочил: 9 917
Krasnoturinsk
Пол: male
Re: Команды telnet помогите пожалуйста
Ответ #1 - 31.08.2015 :: 18:56:18
 
через батник никак ибо батник это один процесс, а телнет другой и никак они меж собой не связаны.  Тебе нужно http://expect.nist.gov, хз правда как оно под виндой, но сборки бинарные есть,

скритп будет типа

log_user 1

set address [lindex $argv 0]
set username [lindex $argv 1]
set password [lindex $argv 2]

spawn telnet ${address}
expect "Login:"
send -- "${username}\r"
expect "Password:"
send -- "${password}\r"
expect "# "
send -- "reboot \r"

Наверх
« Последняя редакция: 31.08.2015 :: 21:14:31 от FiN »  
WWW  
IP записан
 
GenOfDrag
Писатель
*****
Вне Форума


Legend about General of
Dragons

Настрочил: 3 776
Пол: male
Re: Команды telnet помогите пожалуйста
Ответ #2 - 31.08.2015 :: 19:50:29
 
Наверх
 

На моей стороне есть Никто!
 
IP записан
 
FiN
Админ
*****
Вне Форума



Настрочил: 9 917
Krasnoturinsk
Пол: male
Re: Команды telnet помогите пожалуйста
Ответ #3 - 31.08.2015 :: 21:15:53
 
GenOfDrag писал(а) 31.08.2015 :: 19:50:29:

последняя метода как раз советует использовать expect:)
Наверх
 
WWW  
IP записан
 
SEGА
Модератор
*****
Вне Форума


Жить трудно, но с%ка ИНТЕРЕСНО!

Настрочил: 2 519
Краснотурьинск
Пол: male
Re: Команды telnet помогите пожалуйста
Ответ #4 - 01.09.2015 :: 08:19:12
 
Спасибо всем, проблема решена.
ваши решения не подошли, загвоздка встала в том что раскладка клавиатуры должна быть английской.
Наверх
 

Системы охраны и видеонаблюдения
http://sega.3dn.ru
WWW SEGА SEGA_xXx 458753302  
IP записан
 
FiN
Админ
*****
Вне Форума



Настрочил: 9 917
Krasnoturinsk
Пол: male
Re: Команды telnet помогите пожалуйста
Ответ #5 - 01.09.2015 :: 10:16:32
 
SEGА писал(а) 01.09.2015 :: 08:19:12:
Спасибо всем, проблема решена.
ваши решения не подошли

да ты просто их не пробовал, expect - универсальное решение для такгого рода задач подходит для telneta ftp ssh и прочего интерактива, я последний раз его крутил для отправки смс через gsm шлюз телнетом.

SEGА писал(а) 01.09.2015 :: 08:19:12:
загвоздка встала в том что раскладка клавиатуры должна быть английской.

мне чисто для справки, как раскладка клавиатуры влияет на процесс исполнения bat файла?
Наверх
 
WWW  
IP записан
 
Kol
Координатор
Гуру
*****
Вне Форума



Настрочил: 16 597
Краснотурьинск
Пол: male
Re: Команды telnet помогите пожалуйста
Ответ #6 - 01.09.2015 :: 10:44:04
 
FiN писал(а) 31.08.2015 :: 18:56:18:
log_user 1

set address [lindex $argv 0]
set username [lindex $argv 1]
set password [lindex $argv 2]

spawn telnet ${address}
expect "Login:"
send -- "${username}\r"
expect "Password:"
send -- "${password}\r"
expect "# "
send -- "reboot \r"

Ну наверное тут нужно вставить русские символы...  Смех
Наверх
 

11й факт всегда найдется
254107772  
IP записан
 
remx
Писатель
*****
Вне Форума


Услуги поиска информации
в сети интернет. Дорого!

Настрочил: 14 615
default
Пол: male
Re: Команды telnet помогите пожалуйста
Ответ #7 - 01.09.2015 :: 12:56:29
 
Kol писал(а) 01.09.2015 :: 10:44:04:
Ну наверное тут нужно вставить русские символы...  Смех

так?

Code (PHP):
Процедура ОбработкаВнешнегоСобытия(Кто,Что,Зачем)
    Если Кто="LRC_Modem" Тогда
        Если Что="LRC_Modem" Тогда
            Сообщить(Зачем);
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры //ОбработкаВнешнегоСобытия 

Наверх
 

у нас есть печеньки Подмигивание
 
IP записан
 
Kol
Координатор
Гуру
*****
Вне Форума



Настрочил: 16 597
Краснотурьинск
Пол: male
Re: Команды telnet помогите пожалуйста
Ответ #8 - 01.09.2015 :: 13:48:51
 
Ну наверное еще должно быть внедрено послание инопланетянам...
Наверх
 

11й факт всегда найдется
254107772  
IP записан
 
SEGА
Модератор
*****
Вне Форума


Жить трудно, но с%ка ИНТЕРЕСНО!

Настрочил: 2 519
Краснотурьинск
Пол: male
Re: Команды telnet помогите пожалуйста
Ответ #9 - 01.09.2015 :: 15:46:07
 
FiN писал(а) 01.09.2015 :: 10:16:32:
да ты просто их не пробовал, expect - универсальное решение для такгого рода задач подходит для telneta ftp ssh и прочего интерактива, я последний раз его крутил для отправки смс через gsm шлюз телнетом.

мне чисто для справки, как раскладка клавиатуры влияет на процесс исполнения bat файла?

когда стоит русская раскладка то почему то вводится всякая тарабарщина, х3 почему не стал разбираться
...
Наверх
 

Системы охраны и видеонаблюдения
http://sega.3dn.ru
WWW SEGА SEGA_xXx 458753302  
IP записан
 
SEGА
Модератор
*****
Вне Форума


Жить трудно, но с%ка ИНТЕРЕСНО!

Настрочил: 2 519
Краснотурьинск
Пол: male
Re: Команды telnet помогите пожалуйста
Ответ #10 - 01.09.2015 :: 15:48:01
 
С решением помог этот форум
http://forum.kasperskyclub.ru/index.php?showtopic=43649
батник потом в exe переделал с помощью проги ExeScrip
и всё работает
Наверх
 

Системы охраны и видеонаблюдения
http://sega.3dn.ru
WWW SEGА SEGA_xXx 458753302  
IP записан
 
FiN
Админ
*****
Вне Форума



Настрочил: 9 917
Krasnoturinsk
Пол: male
Re: Команды telnet помогите пожалуйста
Ответ #11 - 01.09.2015 :: 21:58:12
 
SEGА писал(а) 01.09.2015 :: 15:48:01:
С решением помог этот форум

так тебе камрад GenOfDrag, ссылку на это решение костыль в третьем посте выдал, а ты говоришь не подошлиУлыбка
Наверх
 
WWW  
IP записан
 
SEGА
Модератор
*****
Вне Форума


Жить трудно, но с%ка ИНТЕРЕСНО!

Настрочил: 2 519
Краснотурьинск
Пол: male
Re: Команды telnet помогите пожалуйста
Ответ #12 - 02.09.2015 :: 08:13:51
 
FiN писал(а) 01.09.2015 :: 21:58:12:
так тебе камрад GenOfDrag, ссылку на это решение костыль в третьем посте выдал, а ты говоришь не подошлиУлыбка

я до форума косперского раньше дошёл чем 3 пост появился ))
Наверх
 

Системы охраны и видеонаблюдения
http://sega.3dn.ru
WWW SEGА SEGA_xXx 458753302  
IP записан
 


Переключение на Главную Страницу Страниц: 1
Печать